Clearstream is built to be fast, beautiful, and secure. To do so, we utilize some of the latest web technologies, which all modern browsers support. If you are using an older, unsupported browser, some features of our web app may not work properly, or at all. In that case, you'll see a warning message encouraging you to upgrade your browser.

Below is a list of the minimum supported version of the most popular browsers. If you're using an older version, we recommend upgrading as soon as possible.

Firefox
78+

Safari
11.1+

Chrome
64+

Edge
79+

Did this answer your question?